Resolved
[US/EU regions] Build and scheduling are degrated
Started , resolved .
Resolved
Both affected regions (Europe and US) are fully recovered. All worker nodes are back online, distributed storage is healthy with full redundancy restored, and workloads have rescheduled and resumed normally.
What happened: An infrastructure configuration change modified a component that manages the container runtime on worker nodes. Applying it restarted the runtime, and on several nodes the runtime came back referencing a file that was momentarily absent during a concurrent reinstall - so the container runtime failed to start and the node dropped offline. Because the change rolled node‑by‑node, it affected several nodes in sequence before we halted it.
Recovery: We stopped the rollout, froze further automated changes, and recovered nodes individually - restoring the container runtime and, where a node's storage client had wedged, performing a clean reboot. Each node was brought back one at a time with storage health verified between steps, so redundancy was never compromised. Customer databases performed standard crash recovery on restart.
Data integrity: No data loss.
Follow‑ups: We are excluding container‑runtime components from routine rollouts, adding a safeguard to prevent the runtime from starting when required files are missing, and moving these node‑level changes to a strictly one‑at‑a‑time, health‑gated process.
We're sorry for the disruption. We'll continue monitoring closely.
Created
We are currently working on restoring the services